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Introduction 
The AcqKnowledge tutorial/demo comes with a variety of prerecorded data files 
and simulates a live recording. While it is impossible to cover every feature of the 
software, many of your questions will be addressed if you use this demo with our 
latest research catalog and the “AcqKnowledge Software Guide” and other online 
support documents (PDF format) provided in the User Support System folder. 

In addition to sample data files, we have included a Quick Start graph template 
(.gtl file). Quick Start files provide all the settings necessary to perform a wide 
variety of experiments. Available Quick Starts are listed in the “Applications” 
section of our RESEARCH CATALOG and our website (www.biopac.com). 

By using the available material, you will be able to simulate the use of the software 
for your particular application. 

AcqKnowledge is incredibly flexible and there are usually many ways to perform 
different analysis functions. If you are unclear about how AcqKnowledge can 
address your specific requirements, please consult with our Application Specialists 
for the most expedient solution. 

Basic Questions 
What is the MP System? 
Each MP System (MP100 or MP150) is a complete and expandable data acquisition system that functions like an on-
screen chart recorder, oscilloscope and X/Y plotter, allowing you to record, view, save and print data. It includes all the 
necessary hardware and software required to turn any computer into a powerful data acquisition workstation specifically 
designed for life science applications. 

Since the MP System takes advantage of the capabilities of your computer, it’s as powerful as larger and more expensive 
data acquisition systems, but has a familiar, easy to use graphical interface. The MP System will reduce your equipment 
setup time and increase the quality of your results. By harnessing the power of your computer, the MP System gives you 
publication quality results with a minimum of effort. 

This guide and the accompanying demonstration highlight some of the features of AcqKnowledge by working through 
some common applications and showing you some sample data files. 

What do I need to run the demo? 
Minimum requirement: Windows 2000 or XP 

 Mac OS X 10.3.x Macintosh users: If installation fails, disable extensions (hold the 
shift key down while you restart the computer) and then repeat 
installation. Restart again to enable extensions. 

What will the demo disk show me? 
The demo pretends the MP100 data acquisition unit is connected to your computer and the software effectively simulates 
the recording of a variety of signals. When you press the  button, data will be plotted on screen exactly as if data 
were actually being recorded from a subject. You can stop the recording at any time. You can then scroll through the data, 
examine specific sections, take readings, and perform analysis. Sample data files are also included: ECG data, EEG data, 
EMG data, respiration data, and—for use with the Specialized Analysis Package for the Mac —Cardiac Output 1 and 
Cardiac Output 2. A graph template file is also included: QuickStartEMG.gtl. 

What can’t I do in the demo? 
Almost all demo software features are exactly the same as in the actual AcqKnowledge program. You cannot save, print, 
use the on-line averaging function, copy measurements or data to the journal, or use the sound option––these are the only 
limitations. 

The MP150 is not demonstrated but software functionality is similar to the MP100, with a few additions to allow for the 
MP150’s increased speed, expanded stimulator features, and Ethernet interface options. 



Hardware configurations 

  
MP150 System MP100 System 

The basic components of the MP System are shown above. All workstations include: 

� MP acquisition unit 

� AcqKnowledge software 

� Universal (non-amplified) module that allows you to connect existing equipment such as pre-amplified 
electrodes, transducers, blood flow meters, force plates, and chart recorders. 

BIOPAC Systems, Inc. manufactures amplifiers and signal conditioning modules designed to measure an array of life 
science data including EMG, respiration, pulse, EEG, temperature, eye movement, skin conductance, evoked potentials, 
microelectrode recordings, electrical bioimpedance, laser Doppler flow, CO2 and O2 gas analysis, and electrogastrogram. 
We also offer a general-purpose amplifier that allows you to connect other devices, including bridge transducers like 
pressure, force, and strain gauges. In addition, you can mix and match amplifiers designed to collect specific kinds of 
physiological signals (such as ECG, respiration, and EMG). These modules snap together, allowing you to create a 
customized data acquisition workstation. 

For MP150 System configurations, AcqKnowledge can be used with multiple MP150 data acquisition units to 

� control multiple, independent experiments on one computer 

� increase the total number of channels used for a single experiment (e.g., 32-channel EEG) 

To synchronize the Start of multiple units, use the External Trigger function. To combine up to 60 channels of data into 
one file, use the Merge Graphs feature. 

Since the data is stored on your computer and can easily be transformed, many 
of the time-consuming setup tasks that other systems require are a thing of the 
past. 

 

 

 

 

 

 

 

 

 

 

 

No calibration required!



Efficient Collection 
The MP System has several advantages over other recording systems. AcqKnowledge is extremely flexible, giving you 
full control over how data is collected. You can analyze your data either while it is being acquired or after the fact. The 
AcqKnowledge software allows you to perform a range of measurements, calculations, and transformations after the data 
has been collected––most can be performed with a click or two of the mouse button. AcqKnowledge comes with over 40 
Quick Starts, which include all the settings for a variety of experimental protocols (which are explained further in our 
RESEARCH CATALOG):  

12-lead ECG Recordings Jewett Sequence 
Animal Studies Langendorff & Working Heart Preparations 
Auditory Evoked Response Lung Volume Measurement 
Autonomic Nervous System Studies LVP 
Biomechanics Measurements Multiple-channel Sleep Recording 
Blood Flow Nerve Conduction Studies 
Blood Pressure Nystagmus Investigation 
Cardiac Output Measurement (Noninvasive) On-line Analysis 
ECG Analysis Pulsatile Tissue Studies 
Einthoven’s Triangle & 6-lead ECG Psychophysiology 
EMG and Force Range of Motion 
Event-related Potentials Real-time EEG Filtering 
Evoked Responses Respiratory Exchange Ratio 
Extra-cellular Spike Recording Saccadic Eye Movements 
Gait Analysis Sexual Arousal Studies 
Heart Sounds Somatosensory Evoked Response 
Indirect Blood Pressure Recordings SpO2 Analysis 
Integrated (RMS) EMG Tissue Bath Monitoring 
Isolated Lung Studies Visual Evoked Response 

 

Since the MP System is a computer-based system, data files can be copied, saved and backed-up like other computer 
files. You can also export data to other programs, either in numerical format for use with programs like Excel or SAS, 
or save data in graphical format and place the images into programs like Word, WordPerfect, or PageMaker. 

While data is being collected, AcqKnowledge also allows you to.... 

� Easily change the number of channels used for collection (up to 16 analog, 16 calculation and 16 digital). 

� Plot the waveforms to make full use of available screen space. 

� Scroll back through the old data while new data is being collected. 

� View recorded values graphically and numerically. 

� Perform, display and store on-line calculations during the recording. 

� Have complete control over acquisition parameters such as variable sample rates, length of recording, and  
when to begin a recording. 

� Use the on-screen annotation and journal while recording data. 

� Store the data directly to any disk or device. The amount of data you collect is limited only by the available 
disk space. 



Let’s begin…  
This demonstration illustrates some of the basic features of 
the BIOPAC hardware and software, and assumes you 
have already installed the AcqKnowledge demo to your 
hard drive (if not, insert the CD and follow the Install 
Wizard). 

To begin, open the AcqKnowledge program: 

PC: use the Windows Start menu  

Mac: double-click on the AcqKnowledge Demo icon 
(and if necessary, select File menu > New > Graph) 

An “Untitled” graph window should be generated. 

Click on the  button in the lower right hand corner 
of the screen and you will immediately see data scrolling 
across the main window (the data was taken from an adult 
male subject). This is a simulated real-time recording, and 
is what you would see during actual use of the MP System. 
Data will be collected for 30 seconds—you may stop the 
demo earlier by clicking on the “Stop” button. (To increase 
the recording period, adjust the “Total Length” in the Set up 
Acquisition dialog box from the MP100/MP150 menu). 

� Click “Yes” if you are prompted to overwrite 
existing data when you click Start. 

 

Recording Data      
One advantage of the MP System is its flexibility. Since 
the MP System AcqKnowledge software uses the familiar 
point-and-click interface, many of the operations that used 
to require mechanical adjustments are now just a mouse 
click away. Now you can change the amount and type of 
data you collect just by clicking the mouse in a dialog 
box. 

To see how easy this is, choose the “Set up Channels” 
item from the MP100/150 menu. You will see three 
columns of boxes next to rows of text boxes that describe 
different types of sample data. If you would like to collect 
and plot sample data for a given channel, check the boxes 
that correspond to the Acquire and Plot columns for that 
channel. 

 For instance, in the real program (not the demo), you 
could deselect the Plot boxes for one or all of the 
Analog channels, which are normally checked for 
plotting at startup in the sample file. 

   When you press  the  button to begin 
acquisition, data will be collected on these channels, but 
that data will not be plotted on the screen as it is being 
acquired. 

 

 

“Setup…” on Mac and for Calc on Windows 



During a recording, when the data plot reaches the 
right edge of the window, the waveforms 
continuously scroll from right to left. For long 
recordings, it may be desirable to view the data 
collected earlier in the acquisition while new data is 
coming in. 

To demonstrate this, go up to the MP menu and 
uncheck Scroll and AutoPlot (the checkmarks will 
disappear). 

Start the acquisition again. 

� Now, when the data plot reaches the right 
limit, the screen will not be re-written. 

At this point, you can use the horizontal scroll bar to look back through the data. 
Note that the scroll bar position indicator is changing while the data collection is 
taking place. This indicates that the record is getting longer as new data is being 
acquired. You can re-select “AutoPlot” to again view  
the new data as it is acquired, and “Scroll” as desired. 

During long recordings, you may wish to do other things with your computer, 
such as word processing. By minimizing or resizing the window, the MP System can be busily collecting data in the 
background while you're using another program. The MP System software will never miss any data. You can even 
reposition the windows to watch the data coming in while you are typing away in your word processing program. 

In addition to the ability to collect data in the background, 
AcqKnowledge also gives you total control over the channel 
acquisition parameters. To illustrate this, choose “Set up Channels” 
from the MP menu. To the left of each channel, the “Acquire” 
checkbox enables acquisition and the “Plot” checkbox enables 
plotting. If Acquire is on but Plot is off, data from that channel will be 
recorded, but not plotted on the screen. After the data is recorded, you 
can turn the channel plotting on by pressing the Option (Mac) or Ctrl 
(PC) key and clicking in the channel boxes at the upper left of the 
graph window . 

The “Values” checkbox will cause the channel’s current value to 
be numerically displayed in the “Input Values” window. Select a 
“Channel” to setup by clicking in the circle next to the channel 
numbers, and edit the “Label” as desired. 
Calculation Channel “Presets” offer an easy way to get started. 
When you choose “Calc” in the Set up Channels dialog, the Presets 

 menu is activated. Click on the  (arrow icon) to generate a 
list of preset options. Use an existing preset, or modify it to create 
a new one, and then organize the channel presets (via the MP 
menu) to suit your needs. Calculation Presets can only work in 
conjunction with Analog input presets, or with other calculation 
channels that are ultimately pointing to an Analog source channel. 
Use MP menu  > Set up Channels > “Setup…” to set the Source 
for a Calculation channel. 

You can easily translate the voltage read by the MP100/150 data 
acquisition unit into the units of the device being measured. Click 
the “Scaling...” (PC) or “Setup…” (Mac) button to generate the 
Change Scaling Parameters dialog and then enter values and a 
units label to convert incoming signals into other units (such as 
ft/lbs, millimeters, liters, etc.). 
 



To instantaneously view the input 
channel values in numerical and/or bar 
chart format, choose “Show Input 
Values…” from the MP menu. This is 
useful for displaying data as it is being 
acquired, and can be especially useful 
for biofeedback procedures. Click on 
the “Options” button to generate 
controls for the size, precision, and 
format of the values in the “Input 
values” window. 

To further control the acquisition, select “Set up Acquisition” from the MP menu to generate the “Acquisition Setup” 
window. This is where you will set up parameters controlling data collection. The basic options are “Sample rate” and 
“Total Acquisition Length.” Sample rate is analogous to the mm/sec setting on a chart recorder. To change it, simply type 
the desired value in the “Sample rate” box or make a selection from the pop-up menu. To set the amount of data to record, 
either adjust the “Total Acquisition Length” scroll box or enter the length value directly. The units for the length can be 
set to samples, msec, seconds, minutes, or hours by clicking on the pop-up menu to the right of the “Total Acquisition 
Length” value. Beginning the acquisition again (clicking on the “Start” button) will cause these new settings to go into 
effect (the demo is locked to an acquisition sample rate of 1000 samples/second). 

  
The storage device can be set to store data to memory, disk, or MP100/150, or, for more sophisticated acquisitions using 
signal averaging, Averaging (the demo is locked to Memory). Any storage medium that you can copy a file to can be 
used (including removable hard disks and optical disks). For most applications, the MP System is limited only by the 
computing environment (system speed, available memory and the like). AcqKnowledge will only let you enter valid 
parameters. 

All acquisition parameters and window positions are 
saved along with the data when the “Save” command 
is chosen. This way you can open a data file and 
collect new data without having to reset any 
parameters. The “Save” dialog box is not available in 
the demo but is shown here for reference. Saving the 
data as an “ACQ” file saves data in a binary file 
format that uses minimal disk space. “Text” is a 
standard ASCII format that can easily be read by other 
programs. PICT (Mac) and WMF (PC) files can be 
read by most drawing and word processing programs. 
The powerful Graph Template feature lets you save 
predefined experiment parameters—then you just open 
a Graph Template and click “Start” to recreate the 
protocol and acquire data under the same settings. AcqKnowledge “Quick Start” Graph Template files are available for 
dozens of applications and can be used as a starting point for customized applications. A sample Quick Start file is 
installed with the Samples folder (open as Type: Graph Template). 



Easy Viewing 
The AcqKnowledge software makes it easy to display and view your data. We have designed the software to provide an 
easy to use interface for working with data and displaying information. AcqKnowledge includes... 

� On-screen measurement tools that can be used to 
instantly find a host of measurements, including 
minima, maxima, intervals, BPM, and more. 

� Functions that allow you to superimpose, tile, 
compress, expand, duplicate, or remove waveforms. 

� Standard computer editing features that allow you to 
cut, copy and paste data using familiar commands. 

� Built-in ability to view several files on the screen at 
the same time. 

� Printing utilities that allow you to produce high-
resolution plots. 

 

 
In the upper left portion of the acquisition window there is a row of small boxes that indicate the acquired channels. The 
box on the left corresponds to the waveform at the top of the screen. The box that appears depressed is the selected (or 
“active”) channel. Only one channel can be selected at a time. The color for each channel’s waveform and indicator box 
correspond and can be changed. Measurements can be taken from any channel, while transformations and editing 
operations apply to the selected channel or, in some cases, to multiple channels. To select a channel, click on the 
waveform using the arrow tool. On the Mac, the axis Grid Locks(s) must be locked for the Grid Tool to function on a 
channel. See the “Read Me” file on the Demo CD for details of Grid Functionality on the Macintosh. 

 

No more manual data extraction!

Channel  
indicator  
boxes 

Vertical scroll bar

Vertical scale region 

Cursor Tools

Active Channel Label 

Horizontal 
Scale Region 

Channel 
labels 

Measurement Region 

Mac only — Grid controls



In the preceding screen shot, channel 1 (ECG) was selected and its indicator box depressed. The “label” of the selected 
channel appears to the right of the channel boxes. The vertical scroll bar adjusts the vertical offset of the selected channel. 
You may use it to slide the selected waveform’s scale up or down. 

To adjust the vertical scale of the 
selected channel, click the mouse on the 
vertical scale region. The vertical scale 
dialog box will be generated. Type in a 
value that is about half the current value 
and click on the “OK” button. The 
selected waveform's screen amplitude 
should now be twice as large as it was 
before. You have complete independent 
control over each channel. 

To display the optimal vertical scale for 
all channels choose “Autoscale 
waveforms” from the “Display” menu. 
(PC users can also access the Autoscale 
option with a right-click on the mouse.) 

You may also compress or expand the displayed waveforms along the horizontal (time) axis. Simply click anywhere in the 
horizontal scale region. The horizontal scale box is generated, allowing any entry. After the “OK” button is pressed, the 
screen will be redrawn with the new time scale setting. 

When grids are locked, the horizontal and vertical scale dialogs will include lock settings and link to grid controls. 

 

 To enlarge a section of interest, use the zoom tool in the lower right hand corner of the window. 
You can hide channels to focus on the channel you will zoom on by pressing the Option (Mac) 
or Ctrl (PC) key and clicking in the channel boxes at the upper left of the graph window. 

 
The zoom tool allows you to select an arbitrary section of data and “zoom in” to examine that area in more detail. To do 
this, press the mouse button and drag the mouse so it forms a box over the desired area. Now release the mouse button and 
you will instantly see the enlarged area (below).  

  
Select “Zoom back” and “Zoom forward” from the “Display” menu to move through zoom levels. 

 



To temporarily hide a channel, click on the channel’s indicator 
box while holding down the Ctrl (PC) or Option (Mac) key.  
The box will be crossed-over and the display will be redrawn 
without this channel. Repeating this operation will cause the 
waveform to reappear. You can hide multiple channels. 

To duplicate or remove a selected waveform, choose “Duplicate” 
or “Remove waveform” from the “Edit” menu. 

To take specific measurements click on the  measurement 
tool in the lower right portion of the window. Select a section of 
the data by clicking and dragging the cursor across the 
waveforms as shown. 
In the example to the right, the interval between two peaks is 
selected. The two peaks occur 0.847 seconds 
apart, which results in a BPM of 70.83825 as indicated 
in the second result window.  

 
The sample data window shown above has two measurement popup menus at the top of the 
window. To increase the number of measurement windows shown, make the window wider or 
increase the number of measurement rows (8 max) in the Display menu > Preferences dialog. 
To change the measurement functions, simply click on the popup menu next to the measured 
value and select a different measurement. To change the channel each measurement is based 
on, choose from the “SC” popup menu. By default, measurements are taken from the selected 
channel (as indicated by SC).  

The values will change while the measurement tool is being dragged over the waveform. 
You can easily measure absolute functions like value, time, and sample number or use functions 
that operate over the highlighted area. These include min, max, mean, ∆ Time, and others. 
The measurement features can be automated so that measurements are taken and pasted into the 
Journal file when a specific event occurs, or at pre-specified user-selectable time intervals. The 
Find Peak function (under the Transform menu) will identify specific events based on a variety 
of threshold and window descriminators or allow you to enter a time period. In the time period 
mode, the software will take the chosen measurement at the defined interval. 

The measurement tool  is also used to edit waveforms. The highlighted area can be cleared, 
cut, copied, or pasted. Data is edited from the selected waveform only. You can copy a section 
of one waveform and paste it in another by selecting the destination waveform before pasting it. 
You can also perform edits (such as pasting) between windows. To copy an entire waveform 
from one window to another, choose “Edit > Select All” and then choose “Edit > Copy,” and 
then switch to the other window and choose “Edit > Insert Waveform.” 
 
 
 
 

 

 

The computer allows you to display several files 
on the screen at one time. Simply select “Open” 
from the “File” menu and make your selection. 
The windows can be moved and resized to ease in 
viewing. Clicking on the window brings it to the 
front. This is very useful for comparing files.  
 
 
 
 



In the actual program, you can 
print out the waveforms as seen 
on the screen by selecting “Print” 
from the “File” menu. The 
AcqKnowledge software supports 
standard output devices (printers, 
plotters) and can produce high-
resolution plots on virtually any 
printer. Print is not available in 
the demo, but a sample printout is 
shown here. 
 
 
 
 
 
 
 
 
 
 
Powerful Analysis 
One advantage of saving data on disk is that you can quickly and 
easily perform post-hoc analyses on your data. AcqKnowledge is 
as powerful an analytical tool as it is flexible. What’s more, the 
software is designed to provide you with immediate feedback from 
each operation. Using AcqKnowledge, you will be able to... 

� Use digital filtering and smoothing. 
� Find patterns within data sets. 
� Automatically find peaks and calculate rate data. 
� Perform mathematical and statistical operations. 
� Log results and observations to a journal. 
� Mark events during acquisition or analysis. 
� Transform data after it has been acquired. 

 
 
An on-line User Support System allows you to access the entire manual while using the system. The AcqKnowledge 
Software and MP Hardware manuals were installed in the  folder in the BIOPAC Demo folder. 
 
To give you an idea of how AcqKnowledge provides immediate feedback, let’s walk through a sample transformation: 
 Windows Users—see page 12 
 Mac users—see page 13 

No need for manual data entry.



Sample Transformation for Windows/PC: (Mac users—see page 13) 

1) Collect at least 30 seconds of sample data (or open the ECGdata.acq from the “Samples” folder). 

2) Select the CH 1 ECG (and if desired, hide the other channels). 

3) Zoom in to highlight one ECG cycle, as shown in the screen shot (use Display>Autoscale waveforms to refine 
selection if necessary). 

  
4) Click on the Transform menu and scroll to select the Find Peak function (see the next page for the dialog that 

will be generated). 

5) Check the Off-line Averaging option (in bottom third of dialog). 

6) Set the first cursor to “Peak + (-.45) sec” and the second 
cursor to “Peak + (+.45) sec.” 

7) Click the “Ave Start” button. 
AcqKnowledge will run through the data and generate a new window showing the average ECG for the entire 
recording. This feature is useful when comparing the ECG complex during different sections of an experiment. 

 
Read more about transformations and event marking in the complete AcqKnowledge Software Guide available under the 
Help menu. 

 



Sample Transformation for Mac: (Windows Users—see page 12) 
1. Collect at least 30 seconds of sample data (or open EMGdata.acq 

from the “Sample Data” folder). 

2. Hide all channels except CH10 EMG . 

3. Zoom in on a burst in CH10 EMG and then use the I-beam cursor 
to highlight the area around one typical EMG spike. 

4. Select  (or Transform>Find Cycle/Peak) to generate the 
Cycle/Peak Detector dialog. 

5. Click the Cycles/Peaks tab and set the Threshold Level by clicking 
the “Use selected maximum” button under the entry box. 

6. Click the Selection tab and set Left edge to Previous peak. 

7. Click the Output tab. 

� Select the Measurements tab and click “Paste measurements for 
each cycle to Journal.” 

� Select the Events tab. 

i. Check the “Output events” box 

ii. Set Event 1 to maximum on CH 10 EMG for Output type 
General>Maximum and output on CH10. 

iii. Set Event 2 to minimum on CH 10 EMG for Output type 
General>Minimum and output on CH10. 

8. Click OK to close the dialog. 

9. Click  (or Edit>Select all) to select all 
data. 

10. Click  (or Transform>Find all 
cycles/peaks) to find all cycles that match the 
criteria. 

� Click “Yes” if prompted to create a 
Journal. 

11. Scroll left to the start of the data file. 

12. Use the Zoom tool to examine event 
definition and placement. 

13. Click or display journal to review pasted 
event text. 

 

Read more about transformations and event 
marking in the complete AcqKnowledge 
Software Guide available under the Help menu. 

 



 

 

 

 

The Transform menu contains a number of functions that 
modify waveform data. 

 

The “Digital Filter” menu item has a sub-menu with both FIR 
and IIR types of filter operations. For most datasets, the default 
filter parameters may be used and will produce relatively robust 
results. 

Several mathematical transformations are available under the 
“Math functions” sub-menu. Some transformations will 
produce a dialog with parameters that can be changed. 

To examine the relationship between two different waveforms, 
the “Template functions” sub-menu provides a host of options. 
The “Integral” transformation results in a running total of all 
selected waveform values (using a trapezoidal rule integration). 
The “Derivative” transformation approximates an ideal 
differentiator. It allows you to specify a low pass frequency to 
filter the data prior to performing the derivative. The 
“Difference” transformation is a running subtraction over the 
number of points specified. 

 

 

The “Equation Generator (Expression)” option lets you 
perform a range of mathematical operations, from addition and 
subtraction to arcsine and log transformations. Now you can 
perform complex operations in a single step. The example to 
the right computes the mean of channels 1, 2, 4 and 5, and then 
arcsine transforms the result and saves the output channel 2 
(you can designate an existing or new channel). You can also 
change the destination to save the output to a new channel, and 
you can transform sections of waveforms or entire waveforms. 

 



  
In addition to performing mathematical functions, the AcqKnowledge software can also search for peaks and calculate rate 
information (such as BPM). For example, suppose you want to calculate the rate for the entire ECG waveform once it has 
been collected. To do this, close the “Averaging” result window and then select “Find rate” from the “Transform” menu. 
The Rate calculation dialog will be generated; a number of options here allow you to customize the Rate calculation. 

� The Rate calculation can operate as a simple threshold detector or can include more sophisticated parameters such 
as noise rejection and windowing. 

� The Find Rate function will calculate the following parameters from a variety of cyclical data: BPM, Hz, peak 
max, peak min, P-P, area, and mean. 

By default, AcqKnowledge will automatically calculate the threshold values and compute the rate for the entire waveform, 
but you can limit the transformation to a selected area. 

 

 

 
One related type of transformation is the histogramming feature, which allows you to display data in summary format and 
examine the central tendency characteristics and variability within a waveform. To see how this feature works, choose 
Transform > Histogram. 

This dialog box prompts you to enter the number of “bins” to sort the values into, and the upper and lower bounds of the 
data to be sorted. Type “50” in the bins entry and click “OK.” The resulting waveform should resemble the histogram plot 
shown here. 

 

 

 
 

As with almost every feature in AcqKnowledge, you can experiment with different settings 
to suit your needs. 



AcqKnowledge also includes tools that allow you to work more efficiently. One such tool is the Stimulator Setup dialog, 
which is useful for creating stimulus signals and other types of output signals. 

The Stimulator Setup dialog allows you to choose 
from a number of  “pre-shaped” waveforms, 
including pure tones, square waves, and ramp 
waves. You can also use the arbitrary waveform 
option to output more complex waveforms. 

To see how this feature works, choose Set up 
Stimulator from the MP100/150 menu. Select 
“1X” from the Repeats section (PC) or “Output 
once” from the center Duration menu (Mac). This 
enables the output options and displays a square 
wave (which is the default). You can easily 
change the type of output waveform by clicking 
on the Waveform icons in the dialog box. To alter 
the characteristics of the signal (duration, 
amplitude, magnitude, frequency, phase, and so 
forth), type in new values in the text boxes below 
the waveform or drag a waveform segment in the 
dialog display. 

 
 

 

AcqKnowledge offers a number of display options, including X/Y plotting. 
You can switch from one display mode to another using the toolbar icons in the 
upper left hand corner of the window. 

  
Scope, Chart, and X/Y plotting toolbar icons 

By clicking on these icons, you can alternately have your display emulate a 
chart recorder, oscilloscope, or plot data from one channel against data from 
another channel. X/Y plots are useful for respiration studies, 
vectorcardiograms, and investigations into non-linear dynamics. 

For some experiments, you may need to record when an 
event (such as a manipulation) occurs. To do this, use the 
on-screen event marker feature. With an open graph 
window (in Chart or Scope mode), click the  Marker 
icon on the Toolbar (or choose Display>Show and then 
scroll to select “Markers” for Windows/PC or “Events” 
for Mac. 

This will activate the event marker display region near the 
top of the graph window. 

Each event marker is represented by an icon and can be annotated with text. To add a new event marker after acquisition, 
position the cursor in the space between the bottom of the marker region and the top of the graph and click the mouse 
button. During acquisition, to enter a global event marker at exactly the time the key is pressed, use “F9” on Windows/PC 
or “Esc” on Mac. Use the event marker tools to jump through the event markers or generate a popup menu that will allow 
you to search for or delete specific event markers. 

 

On the Mac, event markers can be positioned in the event 
marker bar, on the waveform, at the top of the plot, on the 
waveform with an indicator, or on top of the plot with an 
indicator. Click the Event Palette icon on the right edge of 
the Event Tools to review event marking options . 
 
See the AcqKnowledge Software Guide under the Help 
menu for Marker (Event) setup, control, and measurement 
options, including Hotkey setup and automated detection. 

(Editable text label) 



What’s new for AcqKnowledge 
AcqKnowledge 3.8 for Windows/PC 
� Multiple Real-Time Data Views 

� Multiple Hardware Connections (MP150 Systems only) 

� Merge Multiple Graph Files into One File  

� Advanced Averaging (P300 functionality)  

� Dual Stimulation Capability (2 outputs per MP150)  

� Markers: New Options and Automation, Cascade Marker Labels to Prevent Overlap  

� Embedded Archive for Data Comparison  

� Overlap Segment mode  

� Rewind and Erase Last Segment or All Data  

� File Format Options: MATLAB™ Import/Export; Compression  

AcqKnowledge 3.9 for Mac OS™ X 
� All the new features of AcqKnowledge 3.8 (see above) 

� New Calculation Channels: 

� Fourier Linear Combiners � Adaptive Filter  

� New Transformations: 

� Digital Filters: Adaptive Filter 

� Fourier Linear Combiners (FLC) 

� Nonlinear Modeling 

� Autoregressive (AR) Modeling 

� Power Spectral Density 

� AR Time Frequency Analysis 

� DWT Wavelet Transformation 

� Principal Component Analysis 

� Independent Component Analysis 

� Additional File Import/Export Options: Igor Pro Experiment; PhysioNet 

� Batch Files for Acquisition Automation 

� Event Coding & Measurement Automation 

� Cycle (Peak) Detector Interface 

� Expression logic additions: 

� Source—Sample, Pi, True (1), False (0) 

� Function—and, equal, if (2-way), less, not, or, xor (exclusive), ceiling, floor, is infinity, conditional (3-way), 
not a number, floating point modulus, measurement 

� Replay Mode to simulate acquisition  

� QuickTime™ movie creation options  

� Flexible print range: visible area, selected area, or entire file  

� “Friendly” grid scaling & Adaptive Scaling  

� Journal Preferences, new options  

� Multiple undo (user-specified number of levels)  

� BONUS! AcqKnowledge 3.9 for Mac OS X includes a courtesy copy of our new Specialized Analysis package under 
the Transform menu. See a features overview on the next page, and open the AcqKnowledge Software Guide under 
the Help menu to read the Appendix with full details on the Specialized Analysis package. 



 
ECG Analysis 

Detect and Classify Heartbeats 
Locate ECG Complex Boundaries 
Heart Rate Variability  

Hemodynamic Analysis  
ABP Classifier 
Arterial Blood Pressure 
ECG Interval Extraction 
Left Ventricular Blood Pressure 
LVP Classifier 
MAP Classifier 
Monophasic Action Potential 
Preferences: output display format: LVDEP location method; dP/dt pk-pk %; MAP Plateau location method; dP/dt MAP pk-pk 

Impedance Cardiography Analysis  
Body Surface Area 
dZ/dt Derive from Raw Z  
dZ/dt Classifier: B, C, X, Y, and O points 
dZ/dt Remove Motion Artifacts 
ICG Analysis 
Ideal Body Weight 
PEP Pre-ejection Period 
VEPT 
Preferences: output display format; C-, B-, and X-point location methods; Stroke volume calculation method; Body measurement 

units; Body Surface Area method; Ideal Weight estimation method 
General Analysis 

Ensemble Average 
Epoch Analysis 
Principal Component Denoising 
Remove Trend 
Waterfall Plot 
Wavelet Denoising 

Chaos Analysis 
Detrended Fluctuation Analysis 
Optimal Embedding Dimension 
Optimal Time Delay 
Plot Attractor  

Gastric Wave Analysis 
Gastric Wave Analysis 
Gastric Wave Coupling 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Ordering Information 
As you can see from this quick overview, AcqKnowledge for the MP System is a very powerful research tool. The 
analysis and editing software provides you with immediate feedback during analysis, reducing the amount of time needed 
to process data for reports. MP Systems are available for Windows or Mac with USB or Ethernet connectivity. 

Software—————————————————————————— 
AcqKnowledge acquisition and analysis software 

• PC version 3.8 or better 
• Macintosh version 3.9 or better 

 

Hardware—————————————————————————— 
MP 150 Starter System: 

• AcqKnowledge software (specify PC or Macintosh version) 
• MP150 Acquisition Unit (High speed/400 KHz aggregate) 
• UIM100C Universal Interface Module 
• ETHCARD1 Ethernet card 

* ultra-fast and efficient data communications 
* view and control systems across a network—even when 

you’re away from the lab 
• CBLETHX patch and crossover cable for MP1X0 to computer  
• AC150A 12V power supply (USA or Euro) 

MP 100 Starter System: 
• AcqKnowledge software (specify PC or Macintosh version) 
• MP100 Acquisition Unit 
• UIM100C Universal Interface Module 
• USB1W (PC) or USB1M (Mac) USB Adapter 
• CBLS100 analog and digital cable set 
• CBLSERA MP UNIT to computer cable 
• AC100A 12V power supply (USA or Euro) 

Contact—————————————————————————— 

 

BIOPAC Systems, Inc.  
42 Aero Camino, Goleta, CA  93117, U.S.A. 
Phone: 805-685-0066 

Fax: 805-685-0067 

Web: http://www.biopac.com 

E-mail: info@biopac.com 

 

Please contact us to discuss how BIOPAC can provide 
your TOTAL SOLUTION for life science data 
acquisition and analysis! 

 

For the complete line of BIOPAC modules 
and transducers, including specifications 
and application guidelines, visit our website 
at www.biopac.com or see our RESEARCH 
CATALOG.  

 
For questions regarding the interface 
between your equipment or transducers and 
the MP System, please give our 
Applications Department a call. We’ll be 
happy to discuss your specific requirements.


